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1 Introduction
CellDraw is an editing and conversion software tool for PIFF files, as used by
CompuCell3D (CC3D) to specify initial conditions in simulations. It can be useful for
creating initial conditions containing a large number of cells and cell types. Initial
conditions can be designed in a number of ways: e.g. by drawing the cell scenario directly
in CellDraw; by drawing a scene containing cell regions in a paint program, and then
discretize the drawing into a PIFF file; etc.

1.1 Obtaining CellDraw
CellDraw is included with the CompuCell3D distributions, which can be downloaded from
the main CompuCell3D web site repository at http://www.compucell3d.org/.
A separate download is also available to update the CellDraw software version in an
existing CompuCell3D install. An installer is not required: just double-click the appropriate
zip file for your operating system, then place the resulting "CellDraw" folder (and its
related startup script) into your main CompuCell3D install folder, replacing the older
CellDraw directory and files, if there.

1.2 Running CellDraw
To start the application, navigate to the the "CompuCell3D" folder and double-click the
"celldraw.command" file (on Mac OS X) or the "celldraw" batch file (on Windows) or the
"celldraw.sh" file (on Linux) – as in Figure 1. These same files can start CellDraw from the
command line as well.

Figure 1: starting CellDraw
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2 Specifying Initial Conditions in CC3D Simulations
The main components of the CompuCell3D environment (1) are, as in Figure 2,
1.
2.
3.
4.

the computational kernel of CC3D
Twedit++-CC3D - a model editor and code generator
CellDraw - a graphical tool for configuring the initial cell lattice
CC3D Player - a graphical tool for running, replaying, and analyzing simulations

!

!

Figure 2: The CC3D Environment - Main Components

!

Using the CellDraw GUI tool, users can draw regions for in-silico simulation experiments,
and fill them with cells of specified types. CellDraw also allows importing microscope
images for manual segmentation.
The direct import of 3D segmentation files is also available in CellDraw; this functionality
is helpful for example when building a predictive model of zebrafish angiogenesis for
toxicology (2). The automatic conversion of segmented 3D regions, as in Figure 3, is an
important new capability for CC3D, useful to set biologically relevant initial conditions in
3D for any simulation. The imported 3D segmentation files can be those obtained by
TrakEM2 in the FIJI distribution of the ImageJ open source software.
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Figure 3: Direct Import of 3D Segmentation Files

2.1 Initial Conditions in CC3D XML
In CompuCell3D simulations, initial conditions can be defined in a variety of ways. Using
CC3D XML definition files, a simple way to initialize some cells, is for example the
BlobInitializer Steppable1. The CC3D XML code in Figure 4 fills a circle-like area
with cells.
<Steppable Type="BlobInitializer">
<Region>
<Radius>30</Radius>
<Center x="40" y="40" z="0"/>
<Gap>0</Gap>
<Width>5</Width>
<Types>Dark,Light</Types>
</Region>
</Steppable>

Figure 4: CC3D XML: BlobInitializer
Similarly, the CC3D XML code in Figure 5 fills a circle-like area with cells.

1
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see the CompuCell3D Manual (3) for details about Steppables
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<Steppable Type="UniformInitializer">
<Region>
<BoxMin x="10" y="10" z="0"/>
<BoxMax x="90" y="90" z="1"/>
<Types>Condensing,NonCondensing</Types>
<Gap>0</Gap>
<Width>5</Width>
</Region>
BoxMax

</Steppable>

BoxMin

Figure 5: CC3D XML: UniformInitializer
To define the initial conditions for a CompuCell3D simulation, however, it is also possible
to instruct the CC3D simulation code to load a cell scenario from externally defined values,
saved in a separate PIFF file. CellDraw allows such PIFF files to be generated graphically.

2.2 CellDraw: Setting Initial Scene Dimensions
Every time CellDraw is started, it will display a dialog as in Figure 6. The values set in this
dialog box values provide the initial dimensions for the Cell Scene and for the eventual
PIFF file to be used by CompuCell3D.

Figure 6: Set Scene Dimensions Dialog
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The scene dimensions are set to x (width), y (height), and z (depth) values set in the
CellDraw Preferences dialog. These values can be modified later, during scene editing, and
at any time before exporting to a PIFF file.

Figure 7: CellDraw Preferences dialog
Other, more specific preferences related to PIFF Output and Input Image settings are
available in the right-side pane of the full Preferences dialog, when invoked from from the
File→Preferences... menu. These settings can be initially safely left to their default
values, as depicted in Figure 7. More details on these settings are available in section 3.7
(Advanced Settings) below.
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3 Creating PIFF Files
3.1 The PIFF File Format
A PIFF file, as read by CompuCell3D, is a collection of data points representing cell types,
defining the starting conditions for running simulations. In 2D scenes, cell data always
starts at bottom-left coordinates 0,0 and grows with positive coordinates towards the topright corner, as in a standard Cartesian coordinate system. In 3D scenes, the same
convention applies, following a Right-Hand-Side (RHS) orientation for the x-y-z axes.
PIFF files are defined as plain-text format, where each line defines a box-shaped 3D area
filled with pixels belonging to a certain cell type, as in Figure 8 and Figure 9.

The PIFF file format: each line contains...
[cell number] [cell type name] [xLow] [xHigh] [yLow] [yHigh] [zLow] [zHigh]

The biological
name of a cell,
the same name as
in the XML file.
Arbitrary integers.
These represent the
unique cell ids for
manipulating cells in
CompuCell3D.

Box or individual pixel.
Box: [low – high] points represent
the opposite vertices of a box. In
CC3D, the box will become a single
cell of type [cell type name]. Its
unique id will be [cell number].
Pixel: If [low – high] values are
identical, it adds a single pixel to a
cell.

Figure 8: The PIFF File Format
CompuCell3D follows a simple set of rules when loading data from a PIFF file:
• Every cell in the simulation is associated to a numeric cell ID, which is the first
entry in a PIFF line, defined as in Figure 8.
• Any cell can be specified using one or more PIFF lines: multiple PIFF lines with the
same cell ID are useful for defining cells that are not box-shaped (albeit sometimes,
in specific CC3D simulation scenarios, defining non-box cells may not be strictly
necessary: a few preliminary relaxation steps can smooth the shapes of the cells).
• Data appearing later in the PIFF file overwrites data appearing earlier in the PIFF
file, following the opaque paint rule, i.e. painter’s algorithm, to fill the simulation
scene with cell pixels.
As seen in the previous chapter, CompuCell3D allows simple cell scenes to be created
directly in CC3D XML, using specific Steppables such as BlobInitializer and
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z

x=100, y=80, z=120

y
x

x=20, y=40, z=100

in the PIFF file, this cell is defined as:
…
127 Epithelium 20 100 40 80 100 120
…
…

Figure 9: One Line of PIFF Text Example
UniformInitializer. To load cell scenes defined in PIFF files, CC3D provides the
PIFInitializer Steppable.
CompuCell3D can also save the data describing the current cell lattice in PIFF format, for
reusing a specific cell scenario in future simulations, using the PIFDumper Steppable.
Such PIFF files contain one line per pixel, as from the simulation lattice.
PIFF files can be typed directly line-by-line using any text editor; generated
programmatically by a script; or generated by a graphical tool such as CellDraw.

3.2 Options for PIFF Generation
CellDraw has been designed to provide a graphical interface for generating initial
conditions without having to manually type PIFF text files. There are several options for
creating PIFF files in CellDraw:
•
•
•

drawing the cell scenario in CellDraw, either from predefined geometric shapes, or
with free-hand drawing of cell regions
converting images and drawings into PIFF files, where clicking on a color in the
imported image in CellDraw creates a cell region in the PIFF cell scene
the direct import of 3D segmentation files for conversion into 3D PIFF files

The CellDraw user interface consists of three main parts, as in Figure 10:
1. the Cell Scene Editor
2. the Control Panel
3. the Table of Types

3.3 Drawing a Cell Scene in CellDraw
A cell scene in CellDraw is composed of cell regions: each cell region can be of a different
region type, where different region types are distinguished by their color. To draw a new
10
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Figure 10: The CellDraw User Interface:
Control Panel – Cell Scene Editor – Table of Types
cell scene in CellDraw, select the Scene Layer tab in the Control Panel, as is shown in
Figure 10.
Each cell region may contain one or more cells, of different cell types, with different cell
sizes and in different proportions. There can be any number of cell regions in a cell scene.

3.3.1 Creating Cell Regions
To create a new cell region, start by selecting a shape from the New Item pane in the

Figure 11: The Scene Layer tab in the Control Panel:
Edit Mode (Select Tool, Resize Tool) – Region Types (colors)
Control Panel, such as an Ellipse, a Rectangle, or a single 10x10 or 2x2 pixel square cell.
To choose a specific region type for the new cell region, use the color (bucket) tool and its
pop-up menu in the PIFF Types pane, as in the right-side image in Figure 11.
CellDraw 1.5.1 Manual
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Finally, to add a new cell region to the cell scene, click inside the Cell Scene Editor while
the Select Tool (with the white arrow icon) is chosen in the Edit Mode pane, as in the topleft-side image in Figure 11.

3.3.2 Editing Cell Regions
To select a cell region already present in the cell scene, simply click on it. To change a
region's type (and related color), first select the region you want to change, and then use the
pop-up menu of the color tool in the PIFF Types pane to select a new region type.
To move a cell region, make sure that the Select Tool (with the white arrow icon) is chosen
in the Edit Mode pane, as in the top-left-side image in Figure 11, and then click on the
region to select it, and drag it with the mouse.
To bring a cell region to the front, or to send it behind another cell region, or to delete a cell
region, you can use the Item Edit pane tools, or the equivalent entries in the Edit menu.
To resize a cell region, choose the Resize Tool (with the black arrow icon) in the Edit
Mode pane, as in the bottom-left-side image in Figure 11: in this mode, you can click on a
region to bring up a resizing outline around it, then click and drag on its outline corners to
resize it. To resize a cell region while keeping its center fixed instead (i.e. not by dragging
its outline corners), click-and-drag on it with the right mouse button (or with <control>mouse click-and-drag on Mac OS X).

3.3.3 Freehand Drawing of Cell Regions
You can also draw cell regions using the Drawing tools in the Image Layer tab in the
Control Panel, as in Figure 12. These tools are active whether or not an image has been
loaded in CellDraw. For free-hand drawing, select the Freehand Draw pencil tool in the
Image Layer. For polygonal drawing of cell regions, select the Polygon Draw tool.

Figure 12: The Image Layer tab in the Control Panel:
Drawing tools: Freehand Draw, Polygon Draw
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3.4 Converting Image Files into PIFFs
CellDraw can be used to convert external drawings and images into PIFFs, and to import
microscope images for manual segmentation.
One can start by drawing a cell scene in a paint program (not included in CellDraw), such
as Paint, Gimp, GraphicConverter, Photoshop, etc. After saving the drawing to a file in a
common image file format such as PNG, the image can be imported into CellDraw by
using the File→Import Image menu.

Figure 13: Importing an Image in CellDraw
Once an image file is loaded in CellDraw, it can be displayed by selecting the Drawing
tools in the Image Layer tab in the Control Panel, as in Figure 13. When the Image Layer
tab is selected, the loaded image is displayed over the PIFF scene in the region editor.
To see the location of existing cell regions items in the cell scene while in Image Layer
mode, the Image opacity slider can be used to vary the imported image’s opacity. At 100%
opacity, the imported image completely covers any cell regions in the scene, while at 0%
opacity the imported image becomes fully transparent.
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In Image Layer mode, as explained in section 3.3.3 (Freehand Drawing of Cell Regions)
above, one can draw cell regions using the Drawing tools in the Image Layer tab of the
Control Panel – this can be useful for drawing outlines of existing images.
The main purpose of the Image Layer mode is however to allow the manual segmentation
of an imported image’s areas into cell regions, to be exported as PIFF for use in
CompuCell3D.
To create a new cell region from a color area in the imported image, select the Color Pick
tool in the Image Layer pane of the Control Panel, as shown in Figure 13. It is helpful to
reduce the imported image’s opacity while using the Color Pick tool, to discern the newly
added cell regions in the cell scene.

Figure 14: Color Pick creates cell regions from imported images
With the Color Pick tool, clicking on a color region in the Image Layer creates a cell region
in the PIFF Scene, in the same shape as the clicked color region. The new region is filled
with the color that, among the available cell region colors, is nearest to the picked color
from the loaded image.
The Color Pick Threshold slider controls the processing of adjacent pixels having similar
colors in the imported image. Set the slider to the left side for single-color pick, set it to an
intermediate value to allow fuzzy picking of regions having similar colors (setting the slider
fully to the right would pick everything –the entire image- in one click, and is therefore of
scarce use).
The Information pane below the Color Pick tool shows the x-y position of the mouse
pointer in cell scene coordinates, as well as the color of the imported image’s pixel at those
same coordinates. This can be useful to pinpoint a specific color area in the imported
image, from which area the Color Pick tool will create a new cell region.
14
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Figure 15: Importing multiple color areas using Color Pick
Using the Color Pick tool, subsequent clicks on color areas in the imported image create
corresponding new cell regions in the cell scene, as in Figure 15, where a second cell region
is created by clicking on a blue-colored area in the imported image, where the Information
pane below the Color Pick tool shows the color of the imported image’s pixel at x-y mouse
coordinates in the scene.
To edit the newly created cell regions, select the Scene Layer Tab, and use the Select Tool
or the Resize Tool in the Drawing Tools pane.

Figure 16: Editing regions obtained from Color Picking: outline resizing
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For example, Figure 16 shows the outline resizing of one of the cell regions obtained from
the imported image in Figure 13, by clicking and dragging the mouse on one of its outline
corners.
Fixed-center resizing is shown in Figure 17, where another cell region obtained from the
imported image in Figure 13 is resized while keeping its center fixed, by clicking and
dragging on it with the right mouse button (or also with <control>-mouse click-and-drag
on Mac OS X).

Figure 17: Editing cell regions: fixed-center resizing

3.5 Assigning Cell Types to Cell Regions.
A PIFF file contains information about cell types: each cell type is represented by an
alphanumeric string and may not contain blanks (i.e. spaces, tabs, etc). To assing cell types
to your PIFF scene cell regions, use the Table of Types in CellDraw. The table can be
closed and reopened with the Table Tool in the PIFF Types pane in the Scene Layer tab of
the Control Panel. This table contains region cell type choices and their colors, as from the
default CC3D colors for cell types. Only colors and types used by regions in the PIFF
Scene are displayed in the table.

16
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Assigning cell types to
cell regions:
Each cell region is
identified by a color, and
may contain one or more
cell types.
Cell types are randomly
placed within cell regions
of the same color, in
relative proportions as
per chosen amount /
fraction values.
Cells in the PIFF file are
generated as rectangular
blocks of the chosen cell
size for each region color.
Each region color starts with one defined cell type, and the same cell type is assigned to all
the cells, for all regions painted in that color. Additional cell types for a region color can be
added (or removed) by clicking the "+" (or "-") buttons present for each region color.
Each region color may contain an arbitrary number of cell types. These cell types are
randomly placed within each cell region using that color, in relative proportions as per cell
type amount/fraction values assigned in the related list of cell types for each region
(fractions of the total for each region are updated automatically).
For example, one region color could be defined in the table window as containing cell types
Condensing with the amount 1.0, and NonCondensing with the amount 2.0, which would
generate PIFF content for that region containing a random distribution of Condensing type
cells for one third, and of NonCondensing type cells for the other two thirds.
For each region color, the table shows its "Use" in the PIFF Scene, that is the number of
regions using that color.

The table also allows a separate "Cell Size" choice for different sized rectangular grids,
distinct for the different cell region types.
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a. if Fixed Raster is selected, all
cells in all regions will be
saved as square blocks in a
fixed-size raster

b. if Region Rasters is selected
(the default) each region’s
cells will be saved as
rectangular blocks with cell
sizes as set in the Table of
Types

The different values entered in the Cell Size column are used when saving PIFF files if the
Region Rasters mode is selected. If the Fixed Raster mode is selected, the separate Cell
Size choices in the PIFF Regions and Cell Types table is ignored, and PIFF files are
generated using the single raster size value.

3.6 Generating a PIFF File.
In the current release, CellDraw provides three separate ways to export to PIFF files:
1. Fixed Raster mode - in the first and simplest PIFF generation mode, the entire Cell
Scene is subdivided according to a fixed-size square grid, and cells belonging to all
cell regions in the scene are saved as square cells of the same size.
2. Region Rasters mode – in this mode, the cell scene uses separate, different sized
rectangular grids, one for each cell region type, as from the Cell Size column in the
Table of Types.
3. Potts Model mode – to have CompuCell3D compute cells of different target
volumes, allowing for different volumes for each cell type in any region.
Once the scene in the PIFF Scene Region Editor contains all the cell regions as desired
(obtained either from picking color regions from an input image drawing, or by manually
drawing the scene), and all region colors are associated to the desired proportions of cell
types as in the PIFF Regions and Cell Types table, the scene can be converted into a PIFF
file by choosing the File→Export PIFF menu.
After the File→Export PIFF menu is selected, a temporary pop-up window appears to
show the PIFF data generation progress.
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3.7 Advanced Settings
The Preferences dialog contains a number of specific settings that can be safely ignored for
initial PIFF file generation. Their functionality is summarized here:

3.7.1 PIFF Output Settings
•

•

Save metadata in PIFF: Selecting this checkbox will cause the saved PIFF files to
include XML-formatted information about the dataset dimensions, units, etc. This
information is ignored by CompuCell3D releases 3.6 and earlier.
Metadata in header: Selecting this checkbox will position the XML metadata at the
beginning of saved PIFF files. Note: this will save PIFF files that are not readable
by CompuCell3D release 3.6 and earlier. To save PIFF files in a format compatible
with older CompuCell3D releases, de-select this checkbox.

3.7.2 Input Image Settings
•

•

•

PIFF from Region Scene: before saving the PIFF file, this should be turned ON
(...otherwise CellDraw will generate (1!1) pixel-size PIFF entries, discarding any
cell type and proportions choices). It is therefore suggested to leave this checkbox
ON (as by default), unless experimenting with (1!1) pixel-size entries in PIFF files.
Pick color region: this setting enables the generation of cell regions in the PIFF
Scene by picking colors, as in section 3.4 (Converting Image Files into PIFFs)
above. If this checkbox is turned OFF, clicking in the Image Layer will not generate
any cell region in the PIFF Scene Region Editor: it is therefore suggested to leave
this checkbox ON, as by default.
Ignore white regions and Ignore black regions: typically a PIFF file contains a
variety of cell types which CompuCell3D places within the type "Medium". There
is no need to have the type "Medium" actually present in the PIFF file. It is
therefore suggested that either a white background or a black background be chosen
in the input image, and either the Ignore white regions or the Ignore black regions
checkbox be turned ON accordingly, so that no PIFF data is generated for the
background region. If these checkboxes are turned ON (as by default), clicking on a
white or black region in the Image Layer will not cause a new cell region to be
generated in the PIFF Scene Region Editor.
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4 Conclusion
We hope you find CellDraw useful.
For any comments and suggestions, please contact us at http://www.compucell3d.org.
CellDraw is Maintained by IUB and the Biocomplexity Institute.
CC3D™ and The CompuCell3D Environment™ logo are registered trademarks.
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